Symptoms
One of the following screen errors might display when attempting to start/stop your Kaltura Capture recording.
- "Failed to start recording. Please try again."
- "Failed to stop recording. Please try again."
- "Failed to load secondary device. Please restart the application."
- "Failed to load audio device. Please restart the application."
Cause
- Kaltura Capture application is not allowed to record the content of your screen/camera/audio.
Solution
Enable the Privacy Setting on Mac OS using the following steps:
- Close Kaltura Capture.
- Go to 'System Preferences'.
- Click on 'Security & Privacy'.
- Go to 'Screen Recording' and check the box next to 'KalturaCapture' .
5. Restart the application after changes are done to take effect.
To enable the Mac camera permissions.
- Select 'System Preferences' from the Apple menu.
- Click the icon labeled 'Security & Privacy'.
- Click the 'Privacy' tab at the top.
- In the left-hand column, click on 'Camera' to manage app permissions.
- Tick the box next to 'Kaltura Capture' app to grant access to the camera.
- Restart the application after changes are done to take effect.
To enable Mac microphone permissions
- Select 'System Preferences' from the Apple menu.
- Click the icon labeled 'Security & Privacy'.
- Click the 'Privacy' tab at the top.
- In the left-hand column, click on 'Microphone' to manage app permissions.
- Tick the box next to 'Kaltura Capture' app to grant access to the microphone.
- Restart the application after changes are done to take effect.